"Save new account" button solution

Hi All,

I was trying to set up my Bisq and was on “create new account” but the button named “save new accoun” would not ‘activate’. I found another post that indicated the fix was to select the ‘Country of bank’ details from the drop down menus.

As my details were displayed correctly by default I had never done that. I had to select another country & then select my country (originally displayed by default !).

Suggestion: Add an instruction to do this OR leave the fields blank as default so one is forced to use the drop down menus.

All seems good now so I will proceed !

Great project! Thank you.


The devs may want some specific details. Payment method and country for example.

Not necessarily - all the options are in the drop down menus. All that would need to be added is a blank (ie: “-”) option that is default so the user is forced to use the 2 drop-down menus. In my case the country and currency were by default correctly showing but the “Save new account” button was not active which was very confusing because as far as I could see - everything looked correct !!

With which payment method did u experience that? Can you reproduce it?


Apologies - I should have specified it was the “SEPA” option within which one populates your bank details. ( I trust that convention is followable!).

Thank you!

I cannot reproduce the issue. Did you have filled in all the other fields?

Hi, Yes I had every field selected/filled in.

As soon as I used the two drop down menus to select new bank & currency options, then the “Save new account” button became active.

Apologies but in the heat of the monent I did not take screenshots. All good now however it was just very confusing as previously conveyed when you think you have everything filled in & selected correctly but you cannot proceed to save the account details!

Thank you for the comms!

To clarify, I had to use the drop down menu to select another bank (not mine) then select my bank to get the “Save new account” button active.


The “CREATE NEW ACCOUNT” button is not active when you introduce blank spaces in the SEPA account number (I guess this could have been issue originating this post, as many people write blank spaces in SEPA account numbers).

My suggestion would be to accept blank spaces in SEPA account numbers.

Requesting such features is best done on the github (where are the devs).