Security deposit not receiving BTC [solved]

So i am trying to go through with my first purchase and added the funds to my Bisq wallet. The BTC Core wallet shows the transaction being confirmed, but the BTC security deposit is not showing up in the Bisq Wallet. What is going on and how do i rectify this? Appreciate any help! Thanks.

Hello, it’s hard to know without more details. PM for a more private and detailed conversation.

1 Like

How do you do PM here?

@kidaddiction Is it already solved?

For PM, click on your avatar (right side up of this forum) and then the envelope for a new page. There, new message and “huey”.

1 Like

thank you. still not solved. its really frustrating

So out of the blue, after almost a week, the BTC showed up in my Bisq Wallet. Is it normal to take so long? So on one hand I’m happy that I can get my first Bisq purchase to go through, on the other hand I’m concerned that it took so long. Either way, thank you, the community, for taking the time to try to help.

I don’t know why it took so long, and to test ideas you usually have to share personal details, that’s why huey asked you for PM.
Normally, it doesn’t take any longer that any normal transfer between 2 btc wallets.

Next time, specially if you think you’ll have to share personal info or it’s urgent, reach us at

1 Like