Sending BSQ failed - transaction not seen by peers / not confirming [SOLVED]

After being able to obtain access to my old BSQ wallet after facing a problem with an imported BSQ payment account (Can not access newly bought BSQ on imported payment account) I tried to send the contained BSQ to my new BSQ wallet.

However even after extensive waiting the corresponding transaction is not confirming (seen by 0 peers / 0 confirmations).

What may be the reason and what can I do?

Is it possible to either
a) resend the transaction
b) export the privated key from the old BSQ wallet and import it into the new one

See if these steps can help you.

1 Like

Resyncing SPV wallet might be the best way to republish the tx if that is the issue.

1 Like

Reyncing the SPV wallet does indeed help by cleaning the non-published transaction.

However when I try again to send the BSQ I encounter the same problem - transaction not seen by any peers (I’ve resynced the SPV chain twice and everything was in sync).

What else can I do? Is it possible to send or import the BSQ manually using the extracted private keys?

Finally succeeded in sending the BSQ after reducing(!) the default withdrawal fee. :upside_down_face:
Could it be that a transaction is not recognized by peers if the remaining BTC after paying for a transaction is below the dust limit (600 sat)?

Indeed, transactions with outputs below the dust limit (546 sat) won’t be propagated by the network. We have taken some precaution to avoid creating such outputs but perhaps there are more cases.

Are you sure there was an output below dust limit? What did you do to create it, just trying to send a normal BSQ tx?