Snap ends up in prepare stage

Hello! When I start Bisq it ends up as the screenshot shows. It doesn’t freeze (closing the window provides the question and quitting procedure), it doesn’t raise any error, but obviously it’s unusable in this state.

The Bisq app was installed quite some time ago on previous Ubuntu, which was transferred via Deja-dup. (Only Snap was used.)

I didn’t use the app for quite some time. But now I want to access my trades and accounts. Please, assist me in this trouble. I found no relevant information in FAQ, wiki, or Discourse unfortunately.

system: 5.11.0-41-generic #45-Ubuntu SMP Fri Nov 5 11:37:01 UTC 2021 x86_64
app: snap v1.2.7

From my level of knowledge and expertise, I would suggest the following:

  1. backup your data directory somewhere safe: Backing up application data - Bisq Wiki
  2. install latest version of bisq from https://bisq.network/
  3. start and verify that this brand new installation works normally from its fresh data folder, and then shut it down
  4. restore relevant parts of your previous installation into the new one from the data folder backup you made in step 1: Restoring application data - Bisq Wiki

You MIGHT want to skip the “restore your onion address” part, in case you were using a TorV2 address, which is now deprecated and will make Bisq unuseable for you. This will alas mean that your trade peers from the previous installation won’t be able to recognize you.

Thanks for your reply! (In profile settings notifications and emails are separate sections – what a mess.)

Looks like I need some hints, since Bisq files distributed between its version dirs and common dir. How do I restore them to " latest version of bisq from https://bisq.network/"? (I suppose that new installation shouldn’t be a snap, but come from the Deb-package.)

Since you mentioned a deb package, I understand you are under linux, so as per Data directory - Bisq Wiki you should be dealing with /home/<username>/.local/share/Bisq/, so here’s step by step:

  1. stop bisq
  2. mv /home/<username>/.local/share/Bisq/ /home/<username>/.local/share/Bisq.ori/
  3. install new version of Bisq4) follow Restoring application data - Bisq Wiki using /home/<username>/.local/share/Bisq.ori/as source for relevant data to restore

Yeah, it’s an Ubuntu Snap app.

How do I copy files from Snap to Deb-package installation?

Hi there

The Snap page for the Bisq app says they have been unable to update the app past 1.2.7: https://snapcraft.io/bisq-desktop

I think you will have to uninstall the Snap version, then install it from the Bisq downloads page, and then restore your data.

So I think follow @w000000t’s answer above but at point 3 (where they have said ‘install new version’):

using these install instructions: https://bisq.wiki/Downloading_and_installing#OS-specific_install_notes

Then

PS I’m not a developer/expert, just trying to help out, so please make sure you have backups of everything and ask about anything you’re unsure of.

ok, I tried to copy <snap/bisq-desktop/common/.local/share/Bisq/>
hope this will help to access my old account

but now Bisq refuses to take custom Tor bridges! should I open another thread?
without bridges Tor doesn’t work for me, and even generic obsf4 doesn’t help most of time

Question: when should this restoration to be done? Just after fresh Bisq installation, or should it be launched and run to some point before files are restored?

I would, as per my suggestion above, first verify that the new installation connects and starts successfully, and then close it to restore the data I need from the backup

Just tried with another distro… It doesn’t!

I use Deb-package from the download page. Freshly installed Bisq can’t connect to Tor (no surprise here), and offers Tor settings button. I switch it to provided bridges, click Close the window of Tor settings, the shutdown Bisq for restart. After starting it over Tor settings aren’t saved! So there is no chance to connect for Bisq. =(

Also Bisq offers me Agree window after restart, though I already agreed during previous run.

Please share the bisq.log file in your data folder.
Start the freshly installed bisq (no personal information on it), wait for it to fail while connecting, and then close it, after you do it fetch the log file and you can upload it to a file sharing servive, public cloud folder, or privately to me on keybase (same nick)

Here it is! Thanks for your participation!

The log contains both runs I described earlier.

I checked the logs, I only notice that it got up to the point that it was starting Tor, and after nothing happened in that occasion for a couple of minutes, you closed it… I see no errors in the logs.

Let’s start from the beginning: you installed on ubuntu using the deb from Bisq Downloads ‹ Bisq - A decentralized bitcoin exchange network
You made sure that /home/<username>/.local/share/Bisq/ was empty
You started Bisq, and it will just hang there doing nothing as per OP screenshot?

Does Tor Browser work on your system?

Up to this point you describe the sequence precisely.

TB works with bridges! And when I started Bisq I waited until it

So Bisq tries to connect without bridges again (and again).

Ok thank you, I fully understand this now, and sorry for taking so much to realize.
Since you encountered this problem, you might want to open an issue on github at Sign in to GitHub · GitHub
I’ll also page our top start tech support to check this thread out.
Might be useful if you shared a log of a run where you do use the Tor Settings dialogue to set custom bridges, until you shut down Bisq.

Did it! It’s <#5937>.

The thing is, that it is the one when I first make the setting, and second expect it to take effect. But it was just dropped.

Thank you!

ok, so the two logs you shared already cover 1) you setting custom bridges and 2) restarting and expecting bridges to have been saved. Noted.

1 Like