Trade limit downgraded


#1

Hi,

After upgrading to 0.9.1 (without doing anything else) my trade limit was reset, going back to 0.0625. Was that expected?

Thanks


#2

Hi @mirelo ,
Do you know if your onion address with this 0.9.1 upgrade is the same as before ?
It’s in Settings/Network Info/P2P network.
What is your OS also ?


#3

The address in …/btc_mainnet/tor/hiddenservice/hostname is the same in the current installation as in my last backup before the upgrade.

My OS is Linux Mint 19 Tara


#4

ah, that’s strange.

You may find help with this post: How to switch to a new data directory
Following the How to keep my onion address and with that my local reputation? section.

But do all necessary backups before.

Of course, in such cases it’s always better to not have any offers/trades/disputes open.
Hopefully it’s not your case ?

Please keep us informed if this works.


#5

Have you made a new account in Bisq?
It is odd that it can reset itself just like that.

Try restarting your PC of course, as usual, just in case.


#6

I tried creating a new, empty “Bisq” directory and restoring the backup I have from before the upgrade, and the application tells me: Account age: 2 days. My sig.key file still has the same date as in the backup (while its backup has today’s date).

Then I tried:

  • Exporting my account (from the restored installation).
  • Shutting down Bisq.
  • Creating a new, empty “Bisq” dir.
  • Restoring my backup sig.key file into “btc_mainnet/keys”.
  • Starting Bisq.
  • Importing my account.

After doing which the salt (for account age verification) didn’t change, and yet the application tells me my account is only 2 days old, which is false.


#7

I restarted my computer, same thing.


#8

Hm… are you shure the account data and the salt are exactly the same and the sig key is the same.


#9

You can try to delete the AccountAgeWitnessStore file inside the db folder and then restart.


#10

I reinstalled version 0.8.1, and it raised back my trade limit, recognizing the age of my account correctly.

I will now try to delete the AccountAgeWitnessStore and upgrade again to 0.9.1.


#11

I upgraded again to 0.9.1, deleted the file, started the application, and it still says my account is 2 days old.

I closed the application, deleted the file and also the backup directory, restarted the application, same result.


#12

I copied the salt, closed and removed version 0.9.1, reinstalled 0.8.1, restored my backup, started 0.8.1, then checked the salt, and it is the same. Again, 0.8.1 gives me back my old trade limit, recognizing my account’s age correctly.


#13

Thanks for all those trials @mirelo

(… we scratch our heads )


#14

If you have new ideas of what to test to narrow down the problem, please let me know.


#15

I just tested with my own app and could not see any issue. Are you 100% sure you use the same data directory. You could add --appName=Bisq0-8-1 --appName=Bisq0-9-1and to run 2 instances at the same time with the different versions. Downgrading - once u used 0.9 and got back to 0.8 might be problematic (is not tested).
Do you run the default binary or run from a locl jdk (from source)?
As said the relevant file is the sig.key, and the relevant data are the account data (u can export, import) and the salt. If those 3 components are the same all should be correct.


#16

I uninstalled everything, restored my November backup, and installed 0.9.1. Then, I uninstalled everything again, restored my November backup, and installed 0.8.1. My account (with the same salt) had aged the same number of days in both versions, but with its age reset in 0.9.1. It’s as if the reset had happened sometime after the backup but before installation, although that information would not be stored anywhere. Could it be an age overflow due to some field type change?