Trade stuck at "Wait for blockchain confirmation"

Hi I was trying to sell some bitcoin and everything was going fine. I choose fund trade from my bisq wallet then for over 6 hours now everything is stuck at the “Wait for blockchain confirmation” stage.

When I click on the transaction link is saying unconfirmed.

If I search the address in it says unable to decode output address.

It never takes this long so I think something is wrong.

Can somebody please advise what to do next?

copy/paste from just the previous thread

Bitcoin mining fees are quite high for the last days, and right now also (58 satoshis/byte atm).
So, if you didn’t use appropriate fees for your tx, then there will be some delay.
How much fees did you use ?

You may resync your SPV file,
but be aware that if your wallet is old, this can take hours and will consume all your CPU.

I don’t think I touched the fee.

I thought that it was set automatically.

How do I resync my spv file if that is what I need to do?

It’s in Settings/Network Info/Resync SPV chain

Thank you Homard

I might have to give that a try because it does not look like anything else is going to happen,

Is there any risk of me losing any bitcoin if I do this?

I assume everybody is expecting BTC to go up so their sending them all over to have them ready to sell. Or people or just buying. I am stuck with a trade also fo several hours today already.

Its saying that fee is 42.11 sat per byte and size was 379 bytes and fee is 0.0001596 BTC

So that looks correct but still no movement in over 7 hours.

Does anybody know if I do the resync SPV thing that Homard suggested is there a risk of me losing btc?

There is no risk to losing BTC.

How the mempool looks like for the last 24 hours:,24h

OK, I have completed a resync but nothing has changed.

It says that the deposit transaction has been published. The BTC buyer need to wait for at least one blockchain confirmation before starting the payment.

But it has now been 12 hours 30 minutes and still no confirms.

Is there anything else that I can do?

You have to wait it out. I tried several TXID accelerators with my transaction but it is also stuck. How about Bisq implementing a Replace-by-fee option as we have in other Software wallets like Electrum for example. This could help to push transactions and speed up trades when the blockchain is clogged up again, which happens every coupld of months when when FOMO and movement starts in the markets

Bisq fee is on the higher end of the spectrum and we did not had issues since long, but currently if fee rise quickly it can be problematic.
The trade fee cannot be changed by the user, only the tx fee used for normal transfers.

Our fee:
Good estimation service:

Hi Manfred

Thank you for your reply.
So what happens now? It has been 20 hours and still nothing has changed.
I have sold bitcoin before on bisq and never changed the fee and I have never seen a problem like this.
This time I have done everything exactly the same as before.

Fees are reaching record highs those hours (64 sat/byts atm).
I’m afraid the best to do is probably just wait that things calm down.

There are things that I also don’t reallyudnerstand. I have started a bisqfee around 24h ago and the fee used to start the trade was 42sat/B and it still is not confirmed.

While at the same time I have send TX 10h ago an earlier with fees of 10sat/B (not in bisq but electrum) and they have all several confirmations by now. How can those situations happen?

The mining nodes are competing to seal their block the fastest.
But, before sealing, their blocks differ from one node to the other.
Mining nodes are not all equal, and there are certainly mining nodes which are better at filling their block (with high fee tx) than others, and other nodes which still let room for low fee tx.
So, if by chance your 10sat/B tx is in the winner block, you are done.

I don’t really see another explanation. (But I stand to be corrected).


I just wanted to post an update.
My transaction was finally confirmed after over 22 hours.
That is the longest that it has ever taken but at least it got there in the end.

I was starting to worry because I was at work and I checked my phone and seen that the buyers funds had reached my bank account and I did not know at that time if my transaction had confirmed or not.

Anyway all is good now and the trade has been completed.

Thanks everyone for the advice.:grinning:

1 Like

Just for the future, when mempool ist full like this, you will experience up to a week of transactions eeing stuck. Just want to prepare you for the future :slight_smile:

For the records, I faced a similar situation: deal stuck to waiting for blockchain confirmation with the difference that the transaction ID could not be found in any explorer. Problem was that my full node connected over TOR was not responsive, I switched to “Provided Bitcoin Core nodes” and restarted and it went through.
There should be some mechanism in Bisq to identify problems with the custom node like this.

1 Like

Good to hear it went through. It seems as though your node was unable to broadcast the transaction.

You’re right that a message could appear after a certain amount of tries with the suggestion that the user either check their own node or use the “Provided Bitcoin Core nodes”

I also agree it would be good to prompt users to either check their full node or use Bisq’s provided nodes—especially as I think I’m facing the same situation right now on a trade.

However, in the long run, it would be great to figure out how to avoid these kind of stuck transactions. I prefer running bisq against my full node, but it seems that sometimes things go more smoothly if I connect to the default nodes bisq provides.