Trade Timed Out Waiting for Blockchain Confirmation

Trade ID CXOUEV has been stuck for ~2 days on the initial “Wait for blockchain confirmation” step. I cannot pay the seller because it has not progressed to the start payment step. Can you please help? Thanks.

Are you using the latest version of Bitsquare? If not, maybe input transactions are not confirmed.

1 Like

I’m using version 0.4.9.9.3. Is there a more recent version? Looks like the transactions associated with this trade are -0.0018 to create the offer and then -0.0315 withdrawn from wallet. The transaction is for the purchase of 1 BTC.

How do I get this transaction un-stuck. If I don’t complete the trade in time then I believe I get penalized?

Sorry, I’ve read your response a couple times and it’s a bit overwhelming. You may have to dumb it down to laymen’s terms for me to be able to understand.

You have the most recent version, so that is ok.

Sorry for not being clear enough, what I meant to say is that transactions get stuck usually because the miner fees are not sufficiently high, since the fees rapidly increased due to Bitcoin protocol scaling issues. Latest version has that solved and provides sufficient miner fees on all of it’s Bitcoin transactions, however some transactions still get stuck, because some addresses, from which you pay for your security deposit and etc. , still don’t have confirmed balance on them from earlier trades done with older versions or external wallet with insufficient fees. So in order to get them confirmed you can do several things:

the best option is to follow the instructions on the link in the reply above to make another transaction that depends on the stuck ones to get confirmed and set the fees high enough on that one for all of them together, that will incentives miners to accept them all;

another option is to do a double spend with sufficient fees, but that can make some nodes to reject it as an possible attack.

The problem here is just if you have all the keys required to make the transactions you need in case they are locked in a multi-sig or something, but the arbitrator should be willing to work with you on that. Also I believe the arbitrator to be understanding of your issue and not penalize you.

1 Like

Okay, so I’m slowly starting to get it (sorry, I’m relatively new to Bitcoin). When I pull up the trade details it says that the Offer Fee Transaction has been confirmed but the Taker Fee Transaction has not been confirmed.

I checked my settings and it was set to 30 satoshi/bytes for the withdrawal transaction fee. Are you saying that I should 1) set the transaction fee from 30 up to some number that can cover both transactions, 2) send myself some of my own bitcoins? Do I do this by withdrawing funds from one of my Bitcoin accounts to another? How do I link the child to the parent?

1 Like

Well to be honest, I thought the software doesn’t wait for the taker fee to be confirmed, at least it says that in the whitepaper. Maybe the software waits for some other transaction, the security deposit form you or other trader? You can use some online block explorer with the details you have in your Bitsqaure client to pinpoint the exact transaction that is stuck. The point is that you can’t really use the CPFP trick if you don’t own the address the coins are sent to, so if the trade is stuck because of the taker fee, then the arbitrator has to do it and if it is the security deposit one, then I believe the trade protocol can not go as normal since you need to move the funds as soon as they arrive in the multi-sig even tho the trade can’t start.

So I guess you should just wait and if the trade doesn’t finish, then open a dispute and you will be instructed on how to proceed. Or maybe Manfred will reply to you on this forum in the meantime.

1 Like

Only the deposit tx (2of3 multisig) requires at least 1 confirmation. But as the funding and trade fee transactions are inputs for the deposit tx those have to be confirmed as well.
If the funding tx (form external wallet) had a very low fee then the trade might get delayed.

1 Like

Thanks ManfredKarrer and Alexj996 - So can you tell me exactly what I should to to get the transaction un-stuck? I can increase the transaction fee in my settings to a higher number but then what do I do? Please make the instructions as “idiot friendly” as possible, ha! I don’t follow all of the technical stuff and don’t want to mis-interpret and get it wrong. As it is, there may not be enough time to complete this trade.

1 Like

Well I guess there is nothing you can do now. You shouldn’t worry to much if the trade doesn’t happen. It will be investigated by the arbitrator and everything should be sorted out. You should just find the root of the problem, for future reference if nothing else. Go to your external wallet ( where you keep your coins when not using Bitsquare) and check if the fees are high enough. If not, set them correctly for later use.

Thanks. The only external wallets I have are all paper-based and I only keep enough in BitSquare to facilitate purchases. I have increased the transaction fee under my settings so hopefully this corrects the issue moving forward. It seems it may have been set way too low.