Trouble restoring account

I had to reset Windows. After, I was able to recover the btc_mainnet folder. I downloaded and installed Bisq again, closed the program, and replaced btc_mainnet with my backed up folder.

But now when I try to open the Bisq app, it will not load.

Help please

Here’s the frozen Bisq App load screen

Hey that picture did not upload correctly! By it will not load, you mean Bisq wont open at all? Where is it getting stuck?

Prior to replacing the directory was it working?

Hey Bayernator, the picture loaded on my end. It may have on yours also it just appears as though it hasn’t because it’s blank with a tiny icon in the top-left.

Yes, I mean Bisq won’t open at all. The blank window pops up and freezes. Yes, it was working before replacing the btc_mainnet folder.

Hi @Bayernator anything I can do to fix this? Thanks

1 Like

Hey, ya sorry! So it must have to do with the mainnet folder.

I’d recommend giving it another try. Uninstall Bisq and reinstall it… Don’t start it though, replace the btc_mainnet folder immediately then give it a try.

I’ve created my own trouble trying to restore an account, it turned out I didn’t need to. I thought I may have left enough BTC to trade in my account when the hard drive had to be wiped (or so I believed it was being, I have subsequently found some .dll bisq files from early this month, before the crash), the confusion because I had done that but later changed my mind and transferred the BTC, I checked my main wallet to confirm.

When I tried to restore the account it wouldn’t accept more than the first three seed words, any more and all the words became red and the ‘restore wallet’ button greyed out. After a few times I went with the three words and my date and restored my wallet with nothing in it, but now I only have a three word seed backup. I have now uninstalled and reinstalled bisq three times, the last time deleting by hand all files, including the .dll files which the system has dug up from somewhere, but to no effect.

Beginning to surrender to the situation, should I just run with this for the time being? Are three words less secure than 12? In terms of me keeping them secure as in hidden, they either are or they aren’t, I suppose. But it’s fewer words to guess - I’d rather have 12. Is it possible?

This is extremely strange. I am not sure how you are managed to make a 3 word seed work, in my opinion (not an expert) a 3 word seed would amount to nothing. It is extremely unsafe to use that and the private key associated with a 3 word seed could be easily cracked.

12 words is the min, 24 words is preferred! Since you seem to say that that wallet is empty I recommend creating a brand new Bisq wallet with a brand new 12 word seed and too make sure you backup that seed in a safe place!

Do you happen to be using windows to run your bisq wallet?

Yes I am using windows, I don’t like windows. Originally I’d planned to run bisq on my old (15) laptop which has linux installed, but it’s 32bit. I’m thinking of getting another SSD for the desktop for 64bit linux, need to retain windows for Autodesk program. I know I could partition but I don’t want to.

I’d love a brand new wallet! That’s what I thought I’d get if I uninstalled and reinstalled the program, it was a surprise to find I still had the same 3 words I’d used to restore the old wallet. I have done a Qwant internet search ‘how to create a new wallet in bisq’ but am not getting a clear result.

(a few minutes later) a search on chrome has produced a result in reddit and I’ve deleted my wallet file and bisq has made a new one, I now have a brand new wallet with 12 new seed words. How do I increase the words to 24?

Thank you for your feedback, it kicked me to search wider.

I’ve now tried to set the password and - no, this message:

Wallet password could not be set. You might have imported seed words which are not matching the wallet database. Please contact the developers on the Bisq Forum.

That’s great, you took the necessary steps to create a new wallet but it’s still tied to your old bisq directory, that may be why you cannot set a new password ( I am not super familiar with how that works)… BTW that password is for the Bisq application it’s not really tied to your wallet (you don’t need it if you import that seed into other wallet software) Do you have an old password that you used before?

Anyway all that to say that your best bet would be to backup you entire Bisq data directory. Delete the data directory and restart Bisq. This will create a BRAND new directory with a new wallet.

You can then import your account details into the new directory and start “fresh” but while still preserving your account details/age etc. Take a look at this wiki https://bisq.wiki/Backing_up_application_data

You cannot make a 24 seed phrase on Bisq, 12 is the max (and is fine).

Hi Bayernator, I’ve done all that except import my account details, I hadn’t entered any after reinstalling bisq onto the new hard drive, I’m having to start totally fresh but that’s okay, it’s been a useful learning experience. It seems to me one always learns more from mistakes than doing whatever right in the first place. Thanks.

1 Like

Mistakes happen and are a good way to learn as long as we actually learn from them :smiley:

Hopefully all of this works out for you. If you restore your account age and payment account info in the new data directory you should not loose your account signing status etc.