Trying to create an offer to buy BTC but "next step" button stays greyed out. I've done this before and never had an issue, any help is appreciated

Here is a screenshot:

The only difference I can tell from the last time I bought BTC a couple of months ago is that filling in the BTC amount no longer automatically fills in the equivalent fiat amount*, so I fed that in manually as accurately as I could (and tried adjusting the numbers which didn’t make a difference), so all fields are filled as they should be and I have enough BSQ (and BTC, switching the fee toggle between them doesn’t resolve the issue) to pay the fees and everything, but I still can’t create an offer. I’ve just updated the program to 1.9.1 and have reset it several times, I’ve also reset my pc, and synched the DAO when prompted after the update, but it’s still the same. What am I missing?

*side question one: having the fiat/crypto amount no longer automatically calculate one when you feed in the other is really annoying, is there a way to revert to how it used to be?

**side question two: the font on the UI is now nearly impossible to read and I need to put my face right up to the monitor to make any of it out, it was always on the small side, but it’s now practically inaccessible, is there a way to zoom/enlarge that I’m missing? If not, is there a place to ask for this to be made an option? Plenty people have crappy eyesight!

TIA for any help!

For side question 2, I think this could help you: Running on HiDPI screen - Bisq Wiki

Saw your reply to mine on reddit,I’ll just continue here.
I still think sending logs is the best chance, I also think that since you are in the phase of making an offer, there is nothing to censor in said logs, really, but it should be possible to check them briefly before sharing.
In any case, by sending in DM to one support team member on it would be implicitly treated as sensitive data just for troubleshooting purposes.