Unable to withdraw LTC

I’m using Bisq 0.6.7 on Ubuntu 17.10.
After being unable to sell LTC for SEK because of missing arbitrators I wanted to withdraw my LTC. That gives the dialog error:

You need to wait until you are fully connected to the network. That might take up to about 2 minutes at startup.

  • I am connected and syncronized to between 8-12 Litecoin Mainnet peers.
  • Bottom right shows “No seed nodes available”
  • P2P network under “Network info” is empty with “no data available”.

So far I’ve tried:

  • With and without “Use Tor for Litecoin network”.
  • Bridged and non-bridged Tor.
  • Connecting to local full node instead.
  • Using emergency wallet withdraw. - Gives the exact same error.

Terminal output gives two interesting warnings several times per minute:

[DNS seed lookups] WARN i.b.n.DnsLookupTor: Error resolving dnsseed.litecointools.com. Exception: io.bisq.network.DnsLookupException: tor host is unreachable(host=dnsseed.litecointools.com)
[PeerGroup Thread] WARN o.b.n.d.MultiplexingDiscovery: Seed dnsseed.litecointools.com: failed to look up: org.bitcoinj.net.discovery.PeerDiscoveryException: io.bisq.network.DnsLookupException: io.bisq.network.DnsLookupException: tor host is unreachable(host=dnsseed.litecointools.com)


[JavaFX Application Thread] WARN i.b.c.p.f.FeeService: The delivered fee per byte is smaller than the min. default fee of 5 sat/byte

If starting the executable with the switch --socks5DiscoverMode ONION the first two warnings are gone, but the problem persists.

So now I’m out of ideas and hope for some help. :slight_smile:

You can always export your private keys if you need.
You just need to remove wallet password, restart the app and press alt+j.
That should show you your private keys.

Thanks! It did cross my mind that it might be the best fallback solution and when looking into it, it seems quite simple importing them into the core wallet through the console.
Hopefully the funds belong to one of the first keys chronologically, else it’s a really long list to go through.

Edit: OK, all my coins are safely back in my core wallet now. :slightly_smiling_face: It seems like the coins were sitting in one of the top three keys.