Upgraded to 0.9.4, lost all history


#1

Is there a way to restore the history?

Edit: Running on Linux Mint 17.3, 64bit.


#2

Do you have a backup of your old (pre-v0.9.4) data directory ?


#3

I don’t know. I think Bisq automatically creates backups, but I can’t find anywhere in the settings where that backup is supposed to be.

Edit:
I found the following:
~/.local/share/Bisq/btc_mainnet/wallet/backup $ ls -l
total 8
drwxr-xr-x 2 doug doug 4096 Feb 21 21:31 backups_bisq_BSQ_wallet
drwxr-xr-x 2 doug doug 4096 Feb 21 21:31 backups_bisq_BTC_wallet

Keep in mind, I don’t need to restore the wallet. I didn’t lose any Bitcoins. I just want to restore the history of my transactions.


#4

I am not sure. You could try deleting the SPV chain file in Settings, but I have my doubts that would help.

Not sure why you lost your history in the first place. It sounds like a bug.


#5

I tried deleting the SPV file, but still missing the history.


#6

I doubt it is related to the update but rather some weird coincidence with some bug or hard disk write issue. Open the data directory (at account/backup) and look into the db folder. There is a backup folder with a backups_ClosedTrades folder. There u have the latest backups. Try to find the one by date before the issue happened. make a backup before doing anything. shut down bisq and copy the last intact backup and rename it to ClosedTrades and replace the one in the db folder. if u had new added closed trades those would be replaced then with the old file. there is no way to merge it…


#7

Manfred,
Thanks for the help! Actually, you’re right, it looks like the problem actually happened at Feb 14 09:40, days before the upgrade was released. I say this because I found this:
doug@Fujitsu ~/.local/share/Bisq/btc_mainnet/db/backup_of_corrupted_data $ ls -l
total 3352
-rw-r–r-- 1 doug doug 2114062 Feb 14 09:40 ClosedTrades
-rw-r–r-- 1 doug doug 1297224 Jan 5 20:32 DisputeList

I tried to move this ClosedTrades file to the db folder, but since it’s corrupted, a new blank one was created. Is there some kind of maintenance tool I can run against this file to try to fix it?

Thanks!


#8

I fear not. But as said you should find older backups.


#9

No, unfortunately all the backups are newer than the corrupted one.


#10

I found the issue for that and it is fixed on master, so if you run from source you have the fix already. Otherwise in the next release in 2-3 weeks.

The reason was that a few deprecated payment methods (Venmo, CahsApp, OkPay) have been removed from code base and that caused an exception at reading the protobuffer content of the ClosedTrades db file. I added it again and now its fine again. If you had that issue just take the older backup from the db/backup/backups_ClosedTrades folder and replace the ClosedTrades file in the db folder (after you have updated to the new version where the issue is fixed). Make a backup before doing that just to be safe!