V1.8.4. Failed to find JVM

After installation of v1.8.4 on Fedora 34 I get the following error message before any GUI pops up:
Failed to find JVM in “/opt/Bisq/app/runtime” directory.
The Bisq log is not showing any new entry.
Starting an older version works without this problem (until the message that a newer version is installed).
I tried the installation with the rpm file and with the deb file, in both cases the same issue. I verified the signatures. Re-installing Java as well didn’t help.

Anybody else facing the same and is there a fix?


I don’t think I can give useful input for now, but watching as possible source of info to add yet another linux distro in the install instructions of the wiki :slight_smile:
To me, it sounds like the equivalent of when, on windows, a similar error needs the user to copy a specific DLL in the EXE folder.

I think it’s a bug in the bisq software looking for the Java in the wrong path. The path where it’s looking for the JVM isn’t existing. v1.8.2 runs in the same environment.

This case was solved on Matrix chat, user realized they were using version 17 of Java, which is not supported by Bisq (only 11 or 15).
Installing version 11 took care of the issue.

Thanks for the matrix chat support!
Summarizing I had this issue under java 11. Then I switched to 17 which didn’t fix it.
After switching back to 11 and using the following installation instructions v1.8.4 worked fine for me: