Wallet problem + Connection to the bitcoin network failed because of an error : org.bitcoinj.wallet.UnreadableWalletException: Wallet contains Duplicate trasnaction


#21

How do I restore from one of those backup files in the screenshot? The file I had from Januray was an entire copy of the Bisq folder in Appdata and I just saved a copy of the current Bisq in Appdata and replaced it, but these don’t look like the full folder?


#22

The last backup that works is from 05.10.18 @ 7:41 am. All the others are corrupt and say duplicate transactions. I have lost all the bitcoins associated with those sale orders!!


#23

if i take the last transaction from my history it was a sale order for .05 and here is the transaction. My question is who is address “1BMj…” and why have the coins not been returned to my bisq wallet? Where did those bitcoins go?


#24

Please make a SPV resync at settings/network. The old wallet will miss probably txs. After the resync your tx history and balances should be as expected. You can cross check with cmd+e to see the internal wallet balance. It has to be the sum of available+reserved for offers balance in the UI. I assume you dont have open trades. If you have open trades there might be problems but you can continue and if there problems it will end in a dispute and the arbitrator will do then the payout. So if u get a bug in the trade process you can open a dispute with cmd+o.


#25

@ManfredKarrer - The last time my wallet worked properly I had all my BTC in open trades. I was able to resync the SPV and hit cmd+e and see the total balance I should have. It said I could deposit the coins to a BTC address that I provide and I went to do this and my password will not work. This is confusing to me because in order to open the wallet I had to use my password.


#26

Did you forgot your password? You have to take care you cannot mix an old wallet with newer data directory as the database files need to be in sync.


#27

I have .75 BTC coins I can’t get to. If I send you my seed and all the backups I have I will pay you .1 of that .75. You can just send me .65 when you get it to work.


#28

No need to pay me…


#29

I got it working, I can’t believe it!! Not sure what I did I just kept trying different backups and it synced up, I was even able to confirm the $910 transaction it only have 4 hours left before arbitration.

Manfred Thanks for your help!


#30

Good to hear!


#31

Yes, renaming the bisq.spvchain and bisq_BTC.wallet files, and replacing the wallet one with the ones from the backups folder in the wallet subdirectory seems to be the way to fix this.

Went back 10 backups and 7 days, and it bisq opened again.


#32

You have to resync SPV file then to be up to date.


#33

Actually, turned out better not to resync the SPV file.

Once the SPV resync started, the app was showing the progress bar at the bottom until about 60%+.

Then became completely unresponsive and only showed this:


It was still making bisq.log entries, but couldn’t be shut down, and kept the machine like this:
BisqSPVSync2
BisqSPVSync3
This is a strong machine. So, it kept operating normally except for bisq, but after 5 hours or so, the log said:
"INFO b.n.p.n.Connection$InputHandler: proto is null because protoInputStream.read()=-1 (EOF). That is expected if client got stopped without proper shutdown. "

It continued unresponsive, but kept CPU at 100% and 4.3GB RAM and 7.7GB total memory.
(As opposed to the 1.2-2.5GB bisq normally takes.)
It was just repeating the same log entry above.
So, decided to kill it.

Then put the old SPV file back in, and it opened normally all synchronized.

So, whatever it was, seems to have been limited to the wallet file.
Trying to resync spv didn’t help, and on a typical machine would have probably been unbearable or froze it.

So, I guess the thing to try first on this error for the usual user with a wimpy laptop is just to
shutdown the app
rename the bisq_BTC.wallet file
try installing the wallet backups from the backups subdirectory as bisq_BTC.wallet until one of them works.


#34

Thanks for this detailed and very complete return.
Helpful for all.


#35

Yes, thanks for the details. Manfred could maybe have use of your log file as that bug seems severe.
Just make sure that you tell him in a PM if you are sending him your log file that Bisq works for you now, so it is nothing urgent that he has to look into right now.

It is interesting that resync causes such a bug in this scenario.


#36

Yes resyn can be very heavy if the wallet is old and many transactions have been involved. BitcoinJ is not really built for handling such well. From my experience (resynce arbitrator node which was super heavy) it worked out after retry (kill if it hangs too long). But i know thats pretty bad situation. Hopefully we soon get a dev for working on the BitcoionJ part as well to find a way to move to Bitcoin Core in SPV mode…