Wallet problems - what to do

If you have any issues with the Bitsquare wallet, here is a summary of what you can do to fix the issue.

But no worry, as long as you are not losing your wallet file (data directory) or locking yourself out by forgetting the password and not having stored the seed words and not having done any backup, you always can recover the wallet.
No funds lost ever in Bitsquare!

Before doing anything of the below always make a Backup!

There are basically 3 kind of problems which occur sometimes:

  • corrupted spv or wallet file
  • wallet balance is not as expected
  • a bug has caused some inconsistency in the internal wallet database

Corrupted spv or wallet file:
The SPV file gets sometimes corrupted. You will see an error at startup with a “BlockStoreException”.
This is not a big issues as it can be simply deleted and you need to resync (which can take a while - depending on the age and the transactions you had). The SPV file is not containing your keys but only blockchain data which can be re-downloaded.
Beside a corrupted file it could be simply out of sync and to remove it and resync can help to bring your wallet up to date again.

Here are instructions how to fix a corrupted Bitsquare.spvchain:

Wallet balance is not as expected
You can check your wallet balance by adding up the available balance + reserved in offers balance (top bar of the UI).
You can also view the transaction history, export that to cvs and add up all incoming and outgoing amounts to see if it matches what you expect.

Please note that if you have an open trade the funds are not available in your local wallet but locked up in the deposit transaction (MultiSig). That is what you see at the “Locked in trades” balance.

There are 2 special wallet tools which help you to see the state of the internal wallet if the UI does not reflect what you expect.
With cmd+e (or ctrl+e) you can open the emergency wallet tool. Here you see the total available balance. That need to match the sum of what you see at available balance + reserved in offers balance.
Another more sophisticated tool is for displaying the internal wallet data. You can open that with alt+j (or option+j).
There you can see the available balance, all keys (if you check “include private keys” you see the private keys as well) and all transactions as well as other wallet data.

If the balance does not match, please use first the option to resync by deleting the SPV file (see above) and if that does not help, restore the wallet from seed words.
To restore from seed words, go to Account/Wallet seed and copy the current seed word and the wallet date. Then use those for restoring the wallet.
If after a resync the balance is still not correct do another restart.

Another approach is to use one of the backup files (Bitsquare is making rolling backups).
See the following how to restore a corrupted wallet:
https://bisq.community/t/restore-a-corrupted-wallet

Bug has caused inconsistency of the database
If you experiences some sever bug (usually leading to a dispute case) or you had a case of double spend (could have been caused by a bug or by using a not supported features like RBF) it is recommended to start over again with a new wallet and new database to avoid follow-up issues. Double spend detection and handling is basically supported but not well tested as it is an exceptional case.

You must not have any open offers, trades or disputes and you need to withdraw all funds to an external wallet before you remove the data directory. Like always make a backup!

Find more info here how to switch to a new data directory:
https://bisq.community/t/switching-to-a-new-data-directory

1 Like

Hi, Manfred.
Should the wallet be using a lot of memory?
It’s always using about 1 gig. I have 8 in total, so this is a significant load for my laptop.

Also, 5.4% cpu is normal?
Tom

Ram usage is normal. Java is greedy and takes what it gets. If you have less RAM it also works (I tested with 40 instances on one machine and then each app got 200MB and was still working).
CPU depends on the computer and the network activity. If it gets really high do a restart.
I have on a new laptop 2 instances running 24/7 and current cpu usage is 2-3 %. but has peaks in between if many network messages arrive.

Hi @ManfredKarrer,

I’ve just installed Bisq on my laptop (Debian 64 bit). I left funds in my Bitsquare 4.9.9 vers.

I cannot now access the old Bitsquare app. It just fails to load. Please advise on how to access these funds.

Thanks,

Andrew

Wonder if this same problem with Ubuntu recenttly?

Maybe try Modify the config file as per here https://forum.bisq.io/t/solved-0-4-9-9-3-amd64-not-starting-on-debian-9-0-stretch/2302/5?u=shrike

2 Likes

Yes that is prob. the kernel issue. If you have another OS or can revert the kernel or add the VM option mentioned in the other post it should start up again.

1 Like

Thanks @shrike, works a treat!