When buying altcoin Bitsquare failed after deposit payed

Attached is the screenshot of when i try to restart Bitsquare
Copy of the log file is here: http://slexy.org/raw/s20eKiOYeq

The error is [Transaction did not deserialize completely]

What should I do to get the deposit back, or finish the requested transaction?
(I cannot even start the application now)

Hi there,

seems like your wallet is corrupt, I had a similar issue a few days ago. You should ckeck this post from Manfred:

Just make shure you tripple backup your current folder :slight_smile:
Just out of curiosity, are you working on a linux system? My issues started, when the system crashed.

Good luck

Thanks for your reply. Unfortunately,
even if I try to use the oldest backup from “backups_Bitsquare_wallet” I have the same result.

Any other suggestion towards good luck with my issue?

Please have a bit patience. I am working on a hotfix release exactly for that issue:
See https://groups.google.com/forum/#!topic/bitcoinj/mhV9BvoSYMo for more details.
Your wallet will be accessible again with the release (in a few hours).

I am patient - thanks for your work.
When I removed Bitsquare.wallet and startup, I could find in “Portfolio” one “Failed” trade …

u have to move the old wallet back otherwise the internal data get screwed up…

Ok, I can and will do that. For now it is just shut down, and
I will wait until you suggest what to try/do next.

I am very curious whether we will get this trade fixed.

Release is out. Please update and then the wallet should be loaded again.

I can start up with Bitsquare 0.4.9.9.1, see my funds and the failed trade as shown above.
So that works.

I tried to trade again, unfortunately it failed again with what is pictured bellow.
(actually it failed that way the first time as well, I just did not screenshot that)
Trading simply does not work for me so far, and I just burnt 0.001 BTC for each attempt.
So, I do not feel like trying it again.
What would you say?

I am sorry about that issue.
That happens very rarely and is probably an issue at the peers side.
i want to try to take the offer myself so I can debug it better. Will let you know then.

Damn I was too slow. Not the offer is not there anymore. I will observe it if comes again and then try to take it…

I could reproduce it now. I contacted the peer and blocked his offer. Seems to be a bug on his side. Please send me a btc address so i can reimburse you the lost trading fees (was 2 times, right?).

The peer contacted me and we found the issue. He builds from src code and just created the offer when i made a commit which was breaking the P2P network data (which got fixed quickly afterwards). So that caused the issue. he removed the offer and all is fine again.

It is good that you found out what went wrong.
Maybe additional mechanism ensuring that the offer can be actually taken is needed.
It seems like solving the issue of a broken / bogus peer with published offer might be challenging to eliminate.

At the moment I do not have any trades I want to take, but
I really like the idea of distributed exchange you are developing here.

I will be back with some other try later.

Good luck and thanks for your help.

1 Like

It happens very rarely that an take offer attempt fails and the taker loses the fee. But cannot be excluded 100% (bugs, and a very short time window where connection issue can cause is). If it happens we are open to refund the lost fees (if the traders helps us to find the issue and is cooperative).