Why bisq uses 2-4% CPU for audiodg.exe all time?

I noticed that bisq uses 2-4% CPU for audiodg.exe (“Windows Graphisolierung für Audiogeräte”) all the time. Quitting bisq the CPU for audiodg goes to 0% again.
Is that necessary? Can’t bisq only address the program if necessary? bisq doesn’t make sound all the time.

I am not sure, but i think it might have something to do with Bisq playing a silent audio file while running. I think this was to avoid standby mode: Play silent sound to avoid standby mode by ManfredKarrer · Pull Request #1712 · bisq-network/bisq · GitHub

1 Like

Turning the “avoid standby mode” off did not help, even not after a restart of the program. The audiodg.exe still consumes 2-4% CPU, making the fan run a bit faster and louder.
Also I can hear a soft click-clack on the speakers every 10-15 seconds while Bisq is running.

Are you running the latest Bisq version?

v 1.5.9

try delete “C:\Users\username\AppData\Roaming\Bisq\prevent-app-nap-silent-sound.aiff”

Can’t people just set their PC settings to non-standby?
Or we’re doing it for them.

Deleting the “…\prevent-app-nap-silent-sound.aiff” did not help. The file was rebuild at the next Bisq-start and the problem persists.

If you had read my second post, you would have seen that I had already tried that myself. So you don’t have to worry about doing it for me. :neutral_face: