Bisq installation problem


#1

I would like to anonymously purchase some bitcoin with ether. I tried installing Bisq, but I get the following series of messages:

Failed to find library.

C:\Users\John\Appdata\Local\Bisq\runtime\bin\client\jvm.dll

and

Bisq.exe

Failed to locate JNI_CreateJavaVM

and

Bisq.exe

Failed to launch JVM

Help!


#2

Try installing Java first. You can download it here: https://www.java.com/en/download/


#3

OK, so I installed Java, and am still getting the exact same messages when I try to install it.


#4

Did you install the correct binary? 32 bit or 64 bit?


#5

Yes. 64 bit.


#6

May be wrong or unsupported default locale, I had such error during stage starting for FR some time ago. It was exactly similar style - not to find JVM, but by fact was stage starting problem :wink:


#7

@civ1 what local language do you use? Can you locate the log file and look into? And also please say what Windows version do you use.


#8

bisq installed in C:\Users\John\Appdata\Local\Bisq\, please also try to run bisq.exe from windows console -
cmd and look at immediate output.

image


#10

I made a mistake, sorry, in order to find why java-based bisq isn’t started you should run in cmd from the C:\Users\John\Appdata\Local\Bisq\ next command: java -jar app/Bisq.jar.


#11

From the Nodejs 5.1.1 (x64) and npm command prompt I get the following:

C:\Users\John\>C:\Users\John\Appdata\Local\Bisq\ C:\Users\John\Appdata\Local\Bisq\ is not recognised as an internal or external command, operable program or batch file.

C:\Users\John\>java -jar app/Bisq.jar Error: Unable to access jarfile app/Bisq.jar


#12

please run java -jar app\Bisq.jar from C:\Users\John\Appdata\Local\Bisq\, not from C:\Users\John\


#13

In order to navigate to the directory you need to use a command for changing directory called “cd”.
So in the above output your current working directory is C:\Users\John so to go to C:\Users\John\Appdata\Local\Bisq\ you need to run the following command first "cd Appdata\Local\Bisq\"
From there you need to run the “java -jar app\Bisq.jar


#14

Now it starts loading, but gives me the message, “Couldn’t generate key.” If I check obfs4 or use the provided bridges, it doesn’t give me a link. If I restart, it does the same thing.


#15

Please share logs for us.


#16

The file is too large to post, and reporting on github would not be anonymous. What part of the logs would you like to see? (or for what should I be looking?)


#17

Just a wild stab, but I had a similar problem while developing an unrelated project with Java dependency. What happened was that the user had JDK and JRE installed, and JDK was on PATH for “java” command.

Output was similar to the above.


#18

I am syncing bitcoin core (currently at 43.32%), but was hoping to use an Electrum wallet. Could that be an issue?


#19

Well if it is running now then you might not have a problem with java anymore, but I don’t know. Maybe there is something in particular with your java installations and so on that is causing the issue. Reading the log file and looking for some errors or warnings could help debug the issue.

About the bridges and obfs4, there should be a reason for you to use those unless you can’t connect to the Tor network, for example with the Tor browser.

I seriously doubt that your local wallets are causing the issue here. Bisq doesn’t really require or use them when it is run. (it just prefers a local node to connect to for Bitcoin data, but that is unrelated to this, I would say)


#20

If you run from the jar file you use the local JDK and that is missing a certain jar file (bouncycastle). Try to run the exe then you dont have that issue or otherwise build from source like described in the /doc/build.md file.


#21

I had the same issue today. Windows 10 pro. It was solved by giving administrator access to the user. The installation goes to the admin profile and runs fine. If you installed with a user it never finish installing.

I make a shortcut to the admin folder and now is working. If I run the program installed in the user profile I ever get this error.

Manfred, if you need further tests just send me an email. Greetings.