Bisq won't start

I’m trying to run Bisq 1.95 (just updated) on a Mac running OS10.14.6. Bisq ran fine on this machine in the past, but now I can’t make a connection.

Screen Shot 2022-09-26 at 3.21.49 PM
Don’t know if the screenshot will be visible, but it says, "Connecting to the Bisq network failed (reported error: error reply: invalid key type). Please check your internet connection or try to restart the application.
My internet connection works fine for everything else and I tried restarting the app numerous times to no avail.
What does this mean and how can I fix it?
All help greatly appreciated.

  1. Create a Backup. Backing up application data - Bisq Wiki
  2. Stop Bisq if it was running.
  3. Remove Tor files, except hiddenservice. Data directory - Bisq Wiki
  4. Start Bisq.

Related: Error reply: Invalid key type After Upgrading To 1.9.4

Thanks for the help.
I backed up the bisq folder: deleted everything in the original tor folder except the hidden services folder: and restarted Bisq. Same error message. The only difference is that it took only about 30 seconds to appear. Before it took a few minutes.
What else can I try? Should I reinstall Bisq?
All help greatly appreciated.

1 Like

It’s possible there are issues with your tor key, actually. So let’s try this:

  • stop Bisq
  • rename the whole tor folder in data directory to tor.old
  • start Bisq

This will get you a new onion address though, so be warned ongoing trades will not work correctly, if any

Yes! It works :slight_smile:
Thanks very much.

1 Like