Bitsquare don't opens (Ubuntu 16.04)

Hello, today I tried to open bitsquare on the PC, with OS Ubuntu 16.04 and it is impossible, it appears a moment as if it were starting, but in the end it closes.
I have not installed anything on the PC and I have it updated.
I have reinstalled and it does not open either.
The case is that I had a bit of BTC (nothing serious) and I would like to know if I can recover them on another PC with windows 7 (I keep the 12 word key and the folder Backup_Bitsquare_wallet)

Thanks for the help.

You can install Bitsquare on that windows 7 and recover with that wallet file. You can also find the whole application directory at /home/<your_username>/.local/share/Bitsquare with the wallet file as well. You have everything you need, so don’t worry about your BTC.

@ManfredKarrer Seems a lot like the error from

Yes thats strange. Seem the Ubuntu update has caused any changes breaking existing installations. Does anyone has an idea what could cause it?
Backup of data directory (wallet alone is not enough!) and then a re-install should maybe help.

Can u send me that bitsquare.log from the data directory folder?

I have the same issue today. If I run /opt/Bitsquare/Bitsquare, I get Segmentation fault (core dumped).

It was working yesterday. I am running Ubuntu 17.04. The output from uname -a is

Linux prog 4.10.0-24-generic #28-Ubuntu SMP Wed Jun 14 08:14:34 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

I have tried reinstalling Bitsquare-64bit- but that doesn’t help. There are no entries in ~/.local/share/Bitsquare/bitsquare.log with today’s timestamp. Presumably it isn’t getting that far.

This is very worrying. I have pending trades and a lot of Bitcoin in the wallet which I can’t get to.

I have also tried removing Bitsquare completely by doing sudo apt purge bitsquare and rm -rf ~/.local/share/Bitsquare.

I have reinstalled with sudo dpkg -i Bitsquare-64bit- and then run /opt/Bitsquare/Bitsquare. I get an immediate core dump and the local directory is not created.

Then I guess I lost what I had stored, because I only have the 12 word key and the backup wallet. I have reinstalled Bitsquare for 64 and 32, and still no boot.

Then I guess I lost what I had stored, because I only have the 12 word key and the backup wallet.

I do hope this is not the case. I have about 10 XBT in my wallet and several pending trades!

My mistake I think it was just copying the to Backups folder, if you still have all of them, I think you will have no problem.
I hope it goes well.

Did you had a backup? The data dir is in .local/share that should not be affected. backup and move to another OS if it still does not work on Ubuntu. There are several reports, no idea what they broke with that update. If any one find out the solution please share!

1 Like

You need the full data directory. The wallet seed are not enough to continue to use Bisq for trading (missing the p2p network keys and DB). With the wallet seeds though u can always recover the funds u had on your wallet (but not if u had open trades when the funds are in the multiSig).

1 Like

Please see:
how to move the data directory.

Location is: /home/username/.local/share/Bitsquare

I have now tried reverting to a previous kernel. uname -a now reports:

Linux prog 4.10.0-22-generic #24-Ubuntu SMP Mon May 22 17:43:20 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

/opt/Bitsquare/Bitsquare is now running again. Hope that helps.

1 Like

Ok, I do not have open transactions, only BTC stored, since I can not install it and make it work, I’ll try it as soon as I get a team with W7.
I have checked the path .local / share and it seems that all the files are preserved.
Thank you very much for everything, if for some reason I get it to work again, I’ll let you know.

FWIW, I just tried to build from scratch on the latest version using these instructions. Neither bitcoinj nor bitsquare will build, failing with a bunch of cannot find symbol messages.

I assume I am missing a library but, as I know nothing about Java, I’ve given up.

Seems like it isn’t just Bisq that was effected by the kernel update

@Anquiza You can run an old kernel by selecting it on boot.


This has worked, I just rebooted with the previous kernel and Bitsquare has returned to work, without having to do anything else.
@ManfredKarrer @Cliff

Its not starting for me when I click the icon. How do I start Bitsquare from the command line?

In order to run a program form command line you just need to specify it’s location. Assuming the location is /opt/Bitsquare/Bitsquare you just type “/opt/Bitsquare/Bitsquare”, simple as that. Alternatively you can go to the folder where it is installed (exp: “cd /opt/Bitsqaure”) and then run with “./Bitsquare” , since that dot represents current directory (two dots represent directory above).

Running /opt/Bitsquare/Bitsquare gives me Segmentation fault (core dumped)