Create buy offer, wrong currency


#1

When I try to create a buy offer using my Zelle trading account, the “Set amount and price” is set to BTG as the currency, and I can’t change it.

How can I set this to US Dollar?


#2

Ups, that some bug. Can you try to select another payment account and then go back to Zelle? or close it and create newly another offer?
@christoph Can you have a look to that?


#3

I tried both of those steps, but they didn’t help. I also deleted the BTG altcoin account and restarted Bisq, but that didn’t help either.
Also, when I try to edit an offer, it sets BTG as the currency. For example, I created an offer to buy BTC with ETH (before the problem started):


If I try to edit it, this is what comes up:


#4

Can you try to change values in btc amount, price and fiat amount to see if that helps?


#5

I tried adjusting all the parameters, and it doesn’t help. This is happening only with my Zelle and ETH accounts, all the other accounts show the correct currency.


#6

I deleted the Zelle account, and re-created it, and it works fine now.


#7

Weird. We will have a look to it…


#8

I made a backup before I deleted the Zelle account, and the issue is still happening on my ETH account, so if you need any logs or anything let me know.


#9

Can you try to delete the ETH account as well and set it up new? Sorry for the troubles but seems to be an isolated issue…


#10

It won’t let me delete my ETH account right now, because I have an open offer, Once it’s taken I’ll delete the account and recreate it.


#11

Unfortunately, it’s happened again on my newly created Zelle account:


#12

I can now reproduce the bug. Will be fixed in the next release.


#13

Thanks Manfred!


#14

@ManfredKarrer Still having this trouble. What was the issue # on GH that fixed this?

I thought it was fixed by this:


but seems not.


#15

Do you have latest version?


#16

Just tested and could not reproduce it. can you describe how you get the error? Screenshots would be good as well.


#17

Yes, we have the latest version.

We just start the Create Offer dialog.
In some accounts, it’s broken, as shown, in others it’s ok. Some of the ones with the problem are older accounts, and others are newer.

If we create a new account, it works, but then may or may not break for the next Create offer.

So, we can workaround by creating new accounts, but then we lose the account age, and have low limit again.


#18

Did you the use edit offer feature? I will try to find out how to reproduce it, then I prob. can tell you how to work around with existing accounts.


#19

Yes, we edit offers all the time. That works ok.
Only creating offers doesn’t use the right currency on some accounts.


#20

Whcih payment methods do u use?