No splash screen and blank window

In the past few days my Bisq shows a blank (white) window, even after hours it remains like that. I’m running latest 1.2.9 on Windows 10.
Nevertheless the UI seems somehow alive, I got the pop-ups about closed mediation and if I click in the right spot I get the trade currency list as ordinary.
I tried reinstalling the same and also an older version. I tried renaming the local and roaming profile Bisq folders.
What shall I do next? I have an important support ticket expiring on 4th April :frowning:

Hi, this issue was supposed to have been fixed with v.1.2.9. I’d recommend you to DM me your file so I can share it with the devs or share directly with them on the #dev channel on the Bisq Keybase team so it can help the with diagnosis.

All Bisq data is stored in one place:

macOS: /Users/<username>/Library/Application Support/Bisq
Linux: /home/<username>/.local/share/Bisq
Windows 7+: C:\Users\<username>\AppData\Roaming\Bisq
Windows XP: C:\Documents and Settings\<username>\Application Data\Bisq

After having shared it try closing Bisq, deleting file and restarting Bisq.