Offer keeps getting disabled

I created an offer to sell BTC but once active for about 30sec it then disappears from the list and under portfolio the enabled switch is off. No matter how many times i turn it back to enabled it always switches right back after a short time. Tried restarting Bisq but did not help, what else can I do?

edit - version 1.9.4

Check that your computer’s clock is correct. Restart Bisq, maybe it’s a connectivity issue.

Good suggestion but clock is correct, it is matching NIST official time. Tried rebooting the whole system but the problem persists.

I had the same issue with my last offer, but under Portfolio the enabled switch was still on.
In order to see my offer again I kept turning it off and back on for a number of times during a day.
It was so weird I started thinking maybe someone has found an exploit with which he could kick out “competing” offers…

Ha, we must both be paranoid that’s exactly what my first thought was too. But I guess being a little paranoid is why we are on Bisq in the first place. Did you ever find a solution or did it fix itself? It turns off in less than a minute for me so constantly reactivating it is not really an option here

1 Like

Nope I didn’t find any solution. At some point the offer was taken so the thing ended there. It happened a while back and I’ve not made an offer since so I can’t know if the problem persists.
My offer though didn’t disappear every minute like in your case…
After opening Bisq (I also restarted both the app and the system a couple times), the offer would usually disappear very quickly, in 1-2 minutes. Then after turning it off/on again, it would remain for maybe 10-15 minutes. Then after repeating again, it would remain for 30min or an hour, then it would remain for more. At some point I had to go away, so when I came back after many hours the offer was again nowhere to be seen, etc.
Maybe you should open a ticket in Github about this since it’s happening right now for you. I don’t remember why I didn’t open one myself, maybe I thought I was doing something wrong, but since you confirm it’s happening to you too it’s probably some kind of bug (exploit or no exploit).

EDIT: The offer wasn’t disappearing because of a price trigger. I had set one, but it was never approached. Sometimes the offer disappeared in front of my eyes and I made sure to check the current market price against the offer’s deactivation price, so it had nothing to do with it. Also when an offer gets deactivated because of a trigger price that is set, it really gets deactivated (but in my case the offer was still “enabled” in Portfolio, though it wasn’t shown in the offer book).

FYI the github ticket helped find the fix. The DAO was out of sync with an error, once it was re synced the offer stays enabled.

1 Like

One other issue that leads to offers getting automatically disabled, is something Bisq doesn’t like about the maker fee: if that tx doesn’t exist, maybe because the internal wallet is not updated is tries to spend a utxo that’s not there anymore, the tx will be invalid, hence an offer with no maker fee cannot be displayed.
In your case, the DAO wasn’t syncing, so maybe you paid the maker fee in BSQ? In that case, not being up-to-date with BSQ chain could have led to the same outcome.

2 Likes

Yes this is common.

@fasago can you click on your maker fee transaction for the trade to see if is valid?