Please, an arbitrator is needed earlier for blocked trades due to lost data integrity

Hi,I have got several trades from the time period of 11th-14th March what seems they lost data integrity in my Bisq client. And I cannot confirm anything at them (nor payment of the peers, nor mediation proposals). I was on 1.2.8 during them. I reverted to 1.2.7, now I am on 1.2.9, I resynced SPV several times, restarted Bisq client, etc., but still I lost possibility for this set of several trades to confirm anything - also payments of the peers and also I cannot confirm mediation proposals at the trade.
I described the case in GitHub also -
Trades after 2pm starting from 14th March aren’t affected with this issue, I execute them without any problem.

For these several trades from the time period of 11th-14th March, as a seller I got payments from the buyers, but I wasn’t unable to confirm the trade in Bisq wallet due to any bug (there is an error during “confirm the payment”). I tried several times, without results.
We (with our trading peers) went to mediation, mediators proposed the solution to finish the trade (thanks, it was nice of fast job), but I cannot confirm the proposal.

I suppose what is a reason - I don’t have all these transactions in the section FUNDS-LOCKED FUNDS. It seems that my Bisq client lost any information about escrow deposits for these transactions. So this is a reason why I cannot do any action and the error is present. Also a message of the error in Bisq suggest the same things for all these cases. In GitHub I’m attaching the screenshot and the report file.

PLEASE some arbitrator to get finishing those below trades earlier than a standard time to wait for end period of arbitration (about 4th April) and to make the mutlisig payout which will enable buyers to get their BTC now, not in about 20 days:

  1. lixdpd5q-2fe3e778-79b0-4f0c-aa0b-6b890cc5c05c-128
  2. isoBOocS-7c18c3c4-000c-4812-bb1f-145e00aefed4-124 |
  3. ZOJHDEQV-120bc973-2340-4554-ad50-779939c1c642-128
  4. zp3EakDt-01c7988d-75ae-46e9-874e-79c83f9f8b3f-128
  5. nuoiFGM-ec0dff58-e3e3-4dca-88b2-f15254272137-127
  6. 26936560-eee52c02-b9a8-4ca4-830a-8a31010a2fff-117
  7. LGV1S-aa4692ef-44f7-41f2-b1f7-15f835da10dd-128
  8. toKV6Xdf-b08280e0-c482-472e-9fed-5724537e412b-127
  9. 9556496-52b5e774-a02e-4805-bd3a-f0e7315f51ad-128
  10. FTyTW-1d043c57-b4c7-4105-a7df-187a4570d9d3-127
  11. 84084-051bca45-0a11-4fd4-b511-6ddd96e4792a-127

Thank you in advance for any real help from the arbitrator at this issue.

Hey, so you had open trades and reverted to version 1.2.7. Is there a reason for doing this? updating the client and making any big changes such as that can certainly lead to some issues.


No, I reverted later to 1.2.7 by trying resolving all these things on 16th March (due to the official message on GitHub that 1.2.8 is unstable).
The whole situation was generated during working at 1.2.8 in days between 11th and 14th March till about 2pm. Then the situation was finished and all transaction after 14th March 2 pm are executed and confirmed OK.
I suppose that a bug is that with possibility to generate no-limit chain of unconfirmed mempool transactions in Bisq client. I suggest to limit it in a new version of Bisq.

By the way - after this strange case, now during depositing BTC to my Bisq wallet I am awaiting each time minimum for one blockchain confirmation, to avoid such long chain of mempool transactions. This a kind of “hygiene” allows me think that this bug will not happen again.

So all your trades from March 11th - 14th are no longer showing up in your Bisq client? correct? Those trades are the trade Ids you listed above?

The trades from march 11th-14th were going fine until you weren’t able to confirm payment nor accept the mediators resolution? Is this why you reverted to 1.2.7 then to 1.2.9? Your trades should not disappear unless you made a change to the app.

btw you should avoid spending a utxo until it has atleast 1 confirmation.

No, as described above.
Once again - there is a part of trades from the time period 11th-14th March till 2 pm, that got an error in my Bisq client. There are showing up in Bisq as trades.
But they lost data in the FUND-LOCKED FUNDS in the register of the Bisq client (the file “AddressEntryList” in btc-mainnet/db).
So, during any trial of any confirmation (payment or mediation) the error for them is as an example for the trade FTyTW-1d043c57-b4c7-4105-a7df-187a4570d9d3-127:
“An error occurred at task: SignMediatedPayoutTx
Exception message: myMultiSigPubKey from AddressEntry must match the one from the trade data. trade id =FTyTW-1d043c57-b4c7-4105-a7df-187a4570d9d3-127”

As can you see, the error says exactly what I describe.

In my opinion it should be implemented in Bisq client.
People who aren’t geeks will not know that this is dangerous in Bisq for waterfall of potential long chain of unconfirmed mempool transactions.
For mass adoption of Bisq, it should be implemented that one confr\irmation is needed, I think.

And last txs from this part of troubles are:
12. 45727-0a01caa2-8fcf-4519-b132-7dbab131ad1b-127
13. 926623-3bcd9f2b-9ab0-432d-92f1-ed9c190c6fc1-127

Heya, alright we’ll have to investigate each trade independently. Bare with me as i look into this!

See you soon.

DMing you :slight_smile:

Thanks, we’re in touch

Hi. I’m one of the Bitcoin buyers of FlyingAtomPL and I would like to know about the progress of this issue, because I am waiting more than a week to receive my Bitcoin payment. Thanks!

1 Like

@LangLang Thanks for posting here i will DM you :slight_smile:

Maybe you are able to contact with any arbitrator with such kind of my PROPOSAL: an abitrator will communicate with buyers via the interface (all such blocked trades will come to ARBITRATION). Then if the buyer and the arbitrator accept the payment, it will be done via 2-of-3 rule, like in the similar cases of arbitration, without needing to use manual arbitration.

Hey @FlyingAtomPL - - v1.2 of the protocol made changes to how the multisig escrow works. It’s not a 2-3 multisig it’s a 2-2, the arbitrator no longer has a key. So the only way to make a payout is if both parties agree to the med/arbs decision or to do it manually.

Since you ran into a bug which made it so you could not accept the mediators decision and that after attempts to fix this issue you no longer have the trade data in your BISQ client, manual payout may be the best option but the only way to manually pay out is to have both parties info. The alternative is to wait for the timelock to expire and the refund agent to take over the case.

Understood and many thanks for this explanation, also for your involvement at this issue. Seems to be a good plan, as a variant before waiting till 2-4. April (but it is also a n alternative when no manual action is taken).
We can have only a technical problem at this. Please look at the below message from one of the buyers, look like he cannot do anything:

"Hey there, I just got this message in the mediation for this trade (after clicking on the support tab):

‘hi, are you getting this? seems there is an issue with the payout and we will have to do a manual payout, please respond if you see this and I will follow with the details’

But because the mediation has the state closed, I can’t seem to respond. If you’re in touch with the mediator who sent this message (I can’t see who sent it), could you please tell him I saw it and will work with them to get the manual payout."

So, it seems that a buyer cannot take this action also, as demonstrated above.

Hello, I’m one of the byers and I have the same issue. I can’t respond to the arbitrator’s message:

“hi, are you getting this? seems there is an issue with the payout and we will have to do a manual payout, please respond if you see this and I will follow with the details”

Hi. I didn’t receive any message from the arbitrator/mediator yet. The only message I got was the mediators resolution proposal which I have accepted days ago.

@Janony @LangLang
Hi, please re-open the ticket by clicking cmd-U or Ctrl-U and after several minutes it will be possible ro make such an answer (I tried in this way and It worked at me).

If any of you have Keybase, it would be easier to get this done via that chat. my username is @bayernatoor, you can find me in the bisq team chat as well.