Propagating delays

Have sometimes transactions which are for many hours (current example 7 hours for a withdrawal) in the transaction list with Confirmations status “seen by 0 peers”. Have currently 5 transactions in this status. New start of the app didn’t help.
My node is connected to nearly 125 Bitcoin nodes and usually Bitcoin transactions propagate through the network within 1-2 seconds.
Overall I connected bisq with 3 nodes and have 8-12 peers in the app. Some transactions initiated later propagate fast again.
The fee should be irrelevant because it only helps after propagating to be included in a block.

Anyone has an idea why it’s not propagating?


“Delete SPV chain / Recreate” solved the issue.
Read here if you have the same issue:

Happened again with a dispute payout to me which isn’t propagating in the Bitcoin network. If I resync again this will disappear but the 0.01 BTC will be lost (staying at the sending address). And I cannot open a closed dispute. Any idea how to fix this?

You can contact the arbitrator here if you got his onion address.
Just look it up on the forum and your find who is your arbitrator, then you can just PM him telling him the issue and your trade id.

PS: Is your Internet connection stable? It might be that you are experiencing some connectivity issues. Maybe deleting the outdated Tor files in Settings->Network info would help, if your Internet is otherwise good.

Hello, hope you all are well.

Got a similar issue with the difference being that there are supposedly 2 peers having seen that transaction. Checking with a blockexplorer results only in ‘transaction not found’.
Tried all sorts of suggested solutions like, SPV delete, new data directory which resulted in no change. Using the the emergency tool ‘cmd+e’ shows only BTC 0.00
Any help is much appreciated.

Please post the arbitrator address so he can check again if the payout suceeded. You can also check on a blockexplorer if that payout tx was confirmed.
When you run a local BTC node you need to have it synced before starting Bisq.

If you have more weird issues consider to start over with a new data directory. See How to switch to a new data directory

It is quite rare that new data directory doesn’t fix bugs with Bisq.

Perhaps it is something to do with your Internet connection or your system. Of course try restarting your PC just in case and if nothing else works, you could try trading on another system, especially if you use Windows.

Check your Internet connection as well. Perhaps switch to a different wifi to see if there is any difference.

tried all that and I’m not using Windows.
A new data dir creates a new wallet and tor address. It doesn’t make funds available that the system ‘thinks’ it has sent out. But that’s as it looks like to me. Bisq app has created a tx that it’s waiting for to get confirmed but the network hasn’t seen it despite the info that 1 peer has supposedly seen it. This transaction isn’t confirming for months, so I doubt it’s related to the internet connection especially that there aren’t other issues.

trans ID

Maybe you will just have to export your private keys with alt+j to get the funds out.

Not sure what else we could do to try and fix it.

Had a lot of issues in the near past (even with latest version 0.9.1.) and wondered if my installation was ok.
Issues like

  • Waiting 1 minute until I saw a reaction after click a button
  • Many errors (time delay errors …)
  • See above

Since I start the app with a new data directory the issues are 99% gone:
$ /…/…/Bisq --appName=Bisq2

This might not help alf but in case others read it later it’s worth a try … . Of course you need to move your funds to the new addresses, easiest is to start old and new bisq in parallel.

1 Like

As it looks like all is fine.
I thought I initiated a ‘withdrawn from wallet’ transaction for a single deal but somehow it included the security deposits from two finished transactions. The second ‘withdrawn from wallet’ transaction somehow could be initiated despite both (especially the one of concern) security deposits were not available anymore. Which created this never confirming ‘withdrawn from wallet’ transaction.
Thanks for your help/input.