Stuck at "You need to wait until the download of missing bitcoin blocks is complete" for weeks

Updated to v.1.5.6, no change. Please advise.

Windows 10, not sure what other information might be needed

bottom says

“Connecting to Bitcoin network… v1.5.6 / Synchronizing DAO… Bitcoin network peers: 9 / Bisq network peers: 12”

Is there a way to directly contact support?

Join Keybase and #support channel

What is Keybase?

Then search for Bisq channel. In there, will be a #support group dedicated to help.

Why do I need to go elsewhere when this is the bisq website? Can anyone else help me?

Because its where the agents most swiftly help out, live chat - as opposed to a forum.

@Pazza @m52go @MnM

An issue like this could be solved through the forum as it might not need to share personal details, but you might not expect us to solve it as fast as at Keybase.
Anyway, I don’t have any clue on what could be failing. What happens if you try to do something like creating an offer?

Solved. Had to delete SPV file and resync.


Hello. I am first time user of bisq. I am trying to buy btc via Bisq. I have selected trade, sent to my trading wallet required amount of btc to carryout the trade, and I was waiting for confirmation so I could proceed to start with payment for bitcoin. The btc on the way were displayed as locked. I have lost connection and now I can’t see any trades in portfolio tab. What do I do now?? Please advise. Thanks

I think you already reached the support channel, let’s keep the conversation there.