Stuck on Tor issue on startup

My installation of Bisq (1.3.9 MacOS Catalina) was working fine until today, but now it will not start up. Timeline:

  • A trade got stuck due to unconfirmed transaction. I followed the advice here to delete SPV files and restart Bisq.
  • After this, Bisq will not start up due to Tor issues.
  • I have tried all advice I can find here: restarting router, computer, trying with Tor bridges (both recommended and custom), reinstalling the latest Bisq version, running Bisq bort with and without Bitcoin Core. Many of these I tried repeatedly in various time order.

I’m very reluctant to reinstall Bisq fresh since I have BTC and BSQ stuck inside.

Another perhaps relevant point is that I have a PC on the same network where I have never managed to get Bisq running (it just shows a white screen New install not starting up). But it always worked fine on the Mac. My router is a Google Wifi base station.

Any help would be greatly appreciated!

Hmmm interesting. So do you get an error or does it pop up the tor window during boot up? Is there not way to close that window and allow the app to continue loading?

Is tor working fine on your computer?