Stuck open trade status -- releasing the funds

I have took an offer to sell Bisq. The buyer have made the fiat transaction which has already arrived to my account. He has also pushed the “Payment Initiated” button in the program so he is able to see the status “the message reached the network user”.

However, on my side the program was still stuck on the “Wait untill payment has started” status and hence I am unable to release the funds to the counter-party through the program.

My questions are:

  1. am I missing something and there is some way to release the funds in the GUI?
  2. if not, there must be a way to construct the transaction manually and sign with both my key and counter-party key – where are the keys located and what is the easiest way to generate the transaction to sign?


The buyer has actually already started the mediation process – I have confirmed the payment has been received and currently we are just waiting for the mediator reply.

If I understand it correctly – the mediator has not public key but is able to provide assistance and recommendations on who should get the funds.

  1. will there be another option available for the funds release after the mediator replies?
  2. if not, how long does the trading protocol take to the full escalation of the problem to the arbitrator, who, I presume, would be able to forward the BTC as she holds the third private key.


Thanks for any help!

Hi @PrivateScandal can you try the following:

  1. Shut down Bisq
  2. Go to your Bisq directory
  • macOS: /Users/<username>/Library/Application Support/Bisq
  • Linux: /home/<username>/.local/share/Bisq
  • Windows 7+: C:\Users\<username>\AppData\Roaming\Bisq
  • Windows XP: C:\Documents and Settings\<username>\Application Data\Bisq
  1. Go into /btc_mainnet/db/ and delete the ‘PeerList’ file.
  2. Restart Bisq

Thanks @huey, I have tried it, but still there is no option for me to send the funds to the BTC buyer.

Contact your arbitrator so that they can begin to make a manual payout.

Before this you could try to make a backup and Resync the SPV Chain. But I’m not sure of the implications that has on the open trades.
Ping @christoph @alexej996 @ManfredKarrer @sqrrm

Would it also be possible to use the manual payout (Alt+G) instructions to release the funds without the involvement of the arbiter, signing with the buyer and my key? @huey

You certainly can using a tool like over Tor. Reach out to your arbitrator and request their multisig public key. If I’m not wrong, It’s a single one per directory. You can alternatively look for it on the blockchain.
Once you have the three public keys you can recreate the multisig redeem script. If I’m not wrong the order of the public keys is as follow:

  1. Arbitrator
  2. Seller
  3. Buyer

And please create an issue on detailing your troubles.

Similar thing happened to me during a Buy BTC order (I was the buyer) Luckily the seller’s client did not freeze and he was able to release the funds. On my client I was able to send the funds to my external wallet; at the same time, the trade remained in a “waiting for peer to confirm receipt of payment” status and there was nothing I could do except request mediation. After 1 or 2 days the mediator set the transaction in my favor but the trade still remained in a “waiting for seller to confirm receipt of payment” state until one day it randomly disappeared; I don’t know what happened and I don’t believe the mediator was able to resolve anything because even after he forced the trade into a state, it was still stuck in my client. Like I said, I was able to withdraw the funds while the trade was stuck (and before I even contacted Support/mediator) so I was more annoyed than anything and I don’t think anything was really resolved or reported to the development team. I’m sorry I am unable to offer any suggestion but I thought that my experience should at least be reported somewhere, especially if someone else is having a similar problem.

Edit: the only abnormal thing that happened during this trade was when I first clicked the Confirm Payment Has Been Sent button, it timed out and said to try again. I clicked it several times, each time with the same error. I can only assume that this somehow messed up the internal state of the trade for my client; meanwhile the seller must have actually received the first confirmation of payment message but failed to respond to my client.

I have published an issue of this problem:

What would be the way to find out who my arbitrator was/how to contact them (to get their multisig pubkey)? @huey

I pressume without their xpub key I cannot construct the multisig account properly (or can I? I Could actually find out the address from the deposit transaction.).

Then can I do it within Bisq Emergency Multisig Payout tool (Alt+G), or even with an external application?

Also, I have some update about the evolution of the problem:

I have confirmed to the mediator that the payment has arrived and could chat with him in a secret chat (counter party not included, although I didn’t see any problem in that – it might even be desirable). Then, without seeing the suggestion of the solution the mediator stopped communicating.

When I have contacted the other party a few days later, I was told, that the mediator suggested the payout (in the amounts that we agreed initially, returning the safety deposit) and the BTC buyer accepted the proposal. However, I cannot see any any payout button that would appear in my client.

So, we are still stuck without the payout, without proper mediation and it’s already more than two weeks after the trade had happened. I do still see the value of this technology in the decentralisation, privacy etc., but I sort of doubt, that those arguments might convince normal users facing such a problem, no matter how important they are for us.