Trade stuck, unable to confirm receipt of payment, unable to open support ticket


#1

Hello, I have an open money-order-by-mail trade that is stuck. I received payment today and when I clicked the ‘Confirm payment received’ button I started receiving a few different error dialogs that said something like the message was not sent to the trading partner, some error information, and that I need to ask the arbitrator to process. There is no button available to start a support ticket and the ‘Confirm payment’ button is greyed out. There is nothing I can do to complete the trade. All I need is for someone to release the btc to the buyer as soon as possible. This really sucks not having any options whatsoever inside of bisq to try and resolve this issue myself… and no way to get an arbitrator involved either… very frustrating. What can I do? The trade time limit will expire soon and I know the buyer must be getting nervous. He has no idea I received his payment, no way for me to contact him, no way to do… anything! What a mess.

Can anyone please help me get this thing unstuck? Thank you in advance!


#2

Here is the selected arbitrator ID

3de2y2bhifakoa7m.onion:9999


#3

Try opening a dispute with cmd+o to contact the arbitrator.

I think this might be @cbeams’s onion address, but I am not sure.

Either way the buyer should be able to prove that he made the payment anyway and get his BTC, but contacting the arbitrator will make this easier.


#4

ahh… I forgot about cmd+o … will try that now. Thank you


#5

Did you in fact open a dispute? If so, what is the trade ID?


#6

Hey @cbeams I saw that you closed the dispute and stated that you would close out the trade normally, however that trade remains listed in my “open trades” and is still stuck at the same place it was before. Did you close it? Did the buyer receive their BTC? Why does the trade still show as OPEN in bisq? If it is actually closed, how do I get rid of it? Since you closed the dispute ticket I cant even open another one, even using cmd+o, it won’t let me… so now I have even less options than before. This forum is the only avenue left to try and get this sorted out.

Please help. Thanks.


#7

UJ1VUCPS

trade is still open and stuck


#8

Yes, the buyer did receive their BTC payout, just as you received your BTC deposit back. You can follow the deposit transaction through to the payout transaction in a block explorer to observe this for yourself.

I am re-opening and re-closing the dispute on your side now, in the hopes that this will trigger it to actually close on your side. If that doesn’t work, I’m not sure what the solution would be. Please let me know either way.


#9

Hi and thanks for clarifying. Im glad he got his btc, however now this issue seems to have ruined my bisq account. I cannot log in to bisq now because it will not connect to bitcoin mainnet and complains about some “duplicate transaction” … and then never connects at all. Am I screwed now? I had built some relationships with traders and do not want to start from scratch. Is there a way I can remove the offending transactions from my bisq data folder?

Thats the error I get trying to open bisq now. I have over .3 BTC remaining in my wallet. There must at least be some way for me to get that back before I abandon my acount. Please help.


#10

You can try manually deleting “bisq.spvchain” file in “btc_mainnet/wallet” path under your data directory.


#11

Exactly. Thanks @alexej996. @spottedmarley, please let us know if this works. It may not resolve the open trade problem, but it should solve the duplicate transaction problem (btw, this transaction was your payout transaction, which you ended up with two of when I re-closed and re-opened the dispute).


#12

Ok, so I deleted the file but I still get the same “Wallet contained duplicate transaction” error message trying to start bisq. Is there anything else I need to do to force it to refresh?


#13

@ManfredKarrer, any ideas?


#14

@spottedmarley Can you PM me the logs?


#15

Thanks, I just PM’ed you my log files. Let me know if you need anything else.


#16

Thanks. I found what causes prob. the issue and change the for the next release.
Can you confirm that you tried to delete the SPV file from the app (including 2 times restart)?
If that is the case and that did not help to resolve the issue you need to replace the wallet file from an older file from the backup folder or to reset the wallet from wallet seed words.

Here the instructions for the first approach:

  1. Do a backup of the data directory

  2. Go to PATH_TO_DATA_DIR/Bisq/btc_mainnet/wallet/backup and look for the file which is older then: Oct-06 03:28:25
    Take that and rename it to bisq_BTC.wallet and replace the wallet file in PATH_TO_DATA_DIR/Bisq/btc_mainnet/wallet

If you don’t find a file which is older than that date use the latest backup if you have one. If you don’t have a backup you need to use approach 2.

  1. Startup Bisq and once started go to settings/preferences/general and click the Delete SPV file button

  2. Follow the instructions with 2 times restart, have patience it can take a while and CPU might get hot…

After 2 times restart the balance and all txs should be correct.

Second approach:
Go to Account/seed words and restore from the seed words.
After that delete the SPV file as described above.


#17

Thanks for the help. As it turns out I completely forgot that I had installed bisq and copied the data folder onto another machine not long before this all had happened. I started bisq on that machine and it took quite a while to get synced up but it eventually started. It still thought my last three trades were still active, which makes sense, so I cancelled them and all funds returned to my wallet and I am currently in the process of sending my funds out to an external wallet.

I guess I have to figure out some way of getting the original machine to run bisq now though (it still wont start up) because I will lose the trade history for those two successful trades if I stick with this working version of bisq… because it thinks I cancelled those trades now.

What part of the data folder can I copy to the new machine that will include all of my trades and their statuses?

Thanks so much for your help!


#18

Everything is almost back to normal but now I still have this zombie trade that is stuck open and I cannot close it. Here is what I see in my open trades. That trade was completed by @cbeams but it won’t go away and I can’t get rid of it. @ManfredKarrer is there anything I can do to close that one out… forcefully maybe? You can see how it thinks the available balance includes the funds from that trade… even though it also shows there is 0 btc locked in trades right now hehe.


#19

I would suggest to start with a new data directory. If the wallet is already old all gets slower as well and with a new wallet u gain more privacy again.
See: Switching to a new data directory
and
Carry over account age witness to new data directory